Your cart is empty

Do you want to shop our Products?
Explore our FreeStyle Libre 2 Sensor and add it to your Cart.

What is the new minimum operating system requirement for the FreeStyle LibreLink app?

iOS 15.5 is the minimum operating system required to use version 2.10.1 of the FreeStyle LibreLink app.

◊ The FreeStyle LibreLink app is only compatible with certain mobile devices and operating systems. Please check our website for more information about device compatibility before using the app. Use of the FreeStyle LibreLink app may require registration with LibreView.

Loading...