Your cart is empty

Do you want to shop our Products?
Explore our FreeStyle Libre 2 Sensor and add it to your Cart.

I am not currently running Android 12 or above on my mobile device. Do I need to turn ON the Nearby Devices permission?

The Nearby Device permission is only required by Android 12 or above. This permission does not exist and is not needed on Android operating systems lower than Android 12.

Loading...